zju 1789 The Suspects 解题报告

看完并查集,做个题目巩固一下,解题报告还没有写,占个位置先,代码粘贴如下:


/*
ZJU1789The Suspects
【问题描述】
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.


In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).


Once a member in a group is a suspect, all members in the group are suspects.


However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n-1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.


A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
*/
#include <iostream>
//#include <csting>
using namespace std;
int pre[30000];
int rank[30000];
void set(int x)
{
pre[x]=-1;
rank[x]=1;
}
int find(int x)/*功能:查找x的根节点,并返回,同时压缩路径*/
{
int r=x;
while(pre[r]!=-1)
{
   r=pre[r];
}
/*返回根节点,注意还没有完成,开始压缩路径*/
//压缩路径开始:
while(pre[x]!=-1)
{
   int temp=pre[x];
   pre[x]=r;
   x=temp;
}
return r;
}
int unionroot(int a,int b)
{
int t1=find(a);
int t2=find(b);
if(t1==t2)
   return 0;
if(rank[t1]>=rank[t2])
{
   pre[t2]=t1;
   rank[t1]+=rank[t2];//rank数组记录了该节点下的孩子数
}
else
{
   pre[t1]=t2;
   rank[t2]+=rank[t1];
}
return 0;
}


int main()
{
int m,n;
cin>>m>>n;
while(m!=0||n!=0)
{
   for(int ii=0;ii<m;ii++)
   {
    set(ii);
   }
   int nn,x0;
   for(int j=1;j<=n;j++)
   {
    cin>>nn;
    cin>>x0;
    for(int i=1;i<nn;i++)
    {
     int x;
     cin>>x;
     unionroot(find(x0),find(x));   
    }
   }
   cout<<rank[find(0)]<<endl;
   cin>>m>>n;
}
return 0;
}



评论

发表评论

此博客中的热门博文

Linux/ARM Page Table Entry 属性设置分析

提交了30次才AC ---【附】POJ 2488解题报告

笔记